Invalid JavaScript code error warning in NetBeans

Finally I managed to reproduce something that have been annoying me for several months while using NetBeans as my primary JavaScript editor:

netbeans-invalid-js-warning

Filed as issue #159060.

Update: Fixed in trunk and available in 6.7 M2. 🙂